Block propagation issues with Lisk Mainnet

Incident Report for Lisk

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 20:53 UTC

Update

We are continuing to monitor for any further issues.
Posted Jun 12, 2025 - 19:37 UTC

Monitoring

The network outage seems to have been resolved and the blocks have started to propagate. We'll continue to monitor the situation..
Posted Jun 12, 2025 - 19:36 UTC

Identified

Due to an ongoing worldwide network outage affecting all the cloud providers Lisk Mainnet is currently not propagating any new blocks.
Posted Jun 12, 2025 - 19:19 UTC
This incident affected: Mainnet (RPC, Sequencer).