Degraded service on Lisk Sepolia Blockscout

Incident Report for Lisk

Resolved

This incident has been resolved.
Posted Apr 15, 2025 - 11:04 UTC

Monitoring

We've been experiencing DDoS on Lisk Sepolia blockscout explorer. The team has already resolved the issue. And, we continue to monitor the situation.
Posted Apr 15, 2025 - 09:54 UTC