Degraded service on Lisk Mainnet and Sepolia Blockscout explorers

Incident Report for Lisk

Resolved

This incident has been resolved.
Posted Apr 15, 2025 - 16:37 UTC

Monitoring

Both the explorers are now functioning normally and we are continuing to monitor them.
Posted Apr 15, 2025 - 15:40 UTC

Identified

We're currently encountering DDoS attack against our block explorers on both Lisk Mainnet and Lisk Sepolia. The team is currently working on the fixes.
Posted Apr 15, 2025 - 15:00 UTC